Failed: TF30063: You are not authorized to access

Mar 8, 2011 at 11:52 AM

Hi,

I'm getting the following error while trying to connect to TFS;

Testing SubVersion connection...
Connecting to SubVersion... Connected.
There are 31 revisions.

Testing Team Foundation Server connection...
Connecting to Team Foundation Server...
Failed: TF30063: You are not authorized to access 172.16.0.13.

As you can see connecting to subversion is fine, but connecting to TFS is not successful. Under the tfs settings it doesnt ask me for a username and password, where do I enter my TFS username/password.

Hope someone can help;
Cheers

Mar 14, 2011 at 7:29 PM

Hello,

Same issue here.  Is there a solution or work around to this?



Coordinator
Mar 15, 2011 at 9:35 AM

TFS uses a per Windows' session authentication, so if you are in a domain, your domain user is used to login. If the login fails, TFS asks for a user/password.

When the user is authenticated, no account info is asked. But if the user exists and does not have privileges, an error occurs: you are not authorized.

This is not an svn2tfs issue, you should either change you user privileges on the server or login with a different user.

Mar 15, 2011 at 2:45 PM

Thanks for the info, it worked!

My workstation is in a domain and the TFS server is not, I use the same username but different passwords; so all I needed to get this to work was to sync my passwords so they were the same on my workstation and on TFS. Pity svn2tfs can't prompt for a TFS username/password like visual studio but either way it worked so happy, thanks for a great tool!